1
0
Fork 0
Browse Source

UPDATING: Add entry for neovim luajit backend change

main
Adam Weinberger 7 months ago
parent
commit
010b98f9e4
  1. 15
      UPDATING

15
UPDATING

@ -5,6 +5,21 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20220129:
AFFECTS: users of editors/neovim
AUTHOR: adamw@FreeBSD.org
Neovim now uses luajit-openresty as the Lua provider. Many neovim plugins
compile some of their code (Packer does this, as do many LSP plugins).
Neovim will produce errors and fail to load the plugins.
Deleting and reinstalling any plugins that produce errors should fix the
startup.
If you use Packer, you also want to delete the startup cache:
# rm -rf ~/.config/nvim/plugin/packer_compiled.lua
20220128:
AFFECTS: users of net-im/dendrite
AUTHOR: ashish@FreeBSD.org

Loading…
Cancel
Save